EthosCE Service Disruption

Incident Report for Cadmium

Resolved

The issue is resolved. The root cause was a massive bot traffic spike, which has been mitigated at this time.
Posted Jun 27, 2025 - 15:54 EDT

Investigating

Our team is aware there is a service disruption and is working swiftly to identify the root cause.
Posted Jun 27, 2025 - 13:17 EDT
This incident affected: EthosCE.