The issue has been resolved. We will share root cause analysis as soon as possible.
Posted Nov 18, 2025 - 16:28 EST
Monitoring
EthosCE service has been restored. Our team is continuing to monitor the system. If you are still experiencing issues, please notify support.
Posted Nov 18, 2025 - 13:14 EST
Identified
We are aware of disrupted service to EthosCE and are investigating.
Posted Nov 18, 2025 - 10:16 EST
Monitoring
Cloudflare has implemented a fix and is reporting that service is returning to normal. We will continue to monitor the situation.
Posted Nov 18, 2025 - 09:51 EST
Identified
We are monitoring an issue with Cloudflare that is disrupting access to some Cadmium services. Cloudflare status can be checked at www.cloudflarestatus.com and we will update this page when we have more information.
Posted Nov 18, 2025 - 06:55 EST
This incident affected: Eventscribe (Registration, Education Harvester, Website, Mobile App, Expo Harvester, myCadmium, Survey Magnet, Scorecard, Onsite), Elevate (Elevate, Conference365), and EthosCE, Warpwire.