We are continuing to monitor for any further issues.
Posted Apr 13, 2026 - 16:33 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 16:33 EDT
Investigating
Our team is aware of additional service disruptions causing some issues with report generation within Eventscribe Registration and is working swiftly to identify the root cause.
Posted Apr 13, 2026 - 16:11 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 13, 2026 - 15:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 15:54 EDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 13, 2026 - 15:13 EDT
Identified
The root cause has been identified, and our team is working as quickly as possible to fix the issue. Thank you for your patience! We will provide an update as soon as we have more information.
Posted Apr 13, 2026 - 14:42 EDT
Investigating
Our team is aware there is a service disruption causing some issues with report generation within Eventscribe Registration and is working swiftly to identify the root cause.
Posted Apr 13, 2026 - 14:13 EDT
This incident affects: Eventscribe (Registration).