Degraded Performance on Elevate

Incident Report for Cadmium

Postmortem

On September 24, Elevate services experienced performance degradation due to a third-party provider’s inability to handle increased traffic on a specific site, which subsequently impacted our platform. Service performance returned to normal after a system restart. To prevent similar issues, we have opened a ticket with our engineering team to implement safeguards, strengthen monitoring, and improve resiliency going forward.

Posted Sep 29, 2025 - 12:09 EDT

Resolved

The issue has been resolved. We will share root cause analysis as soon as possible.
Posted Sep 25, 2025 - 15:42 EDT

Monitoring

A fix has been put in place, and service has been restored. Our team is continuing to monitor the system.
Posted Sep 24, 2025 - 12:51 EDT

Identified

Our team has identified the root cause of the degraded performance and is working diligently to provide a fix to this issue. Thank you for your patience.
Posted Sep 24, 2025 - 12:33 EDT

Update

We are continuing to investigate degraded performance on Elevate sites. The team is working diligently to identify the root cause and provide a fix to this issue. Thank you for your patience.
Posted Sep 24, 2025 - 11:50 EDT

Investigating

We are actively investigating reports of degraded performance on Elevate sites. The team is working diligently to identify the root cause and provide a fix to this issue. Thank you for your patience.
Posted Sep 24, 2025 - 10:34 EDT
This incident affected: Elevate (Elevate, Conference365).